RIT Installation Instructions

Table of Contents

Introduction .......................................................................................................................................................... 2
Introduction to Excel VBA (Developer) ........................................................................................................ 3
API Commands for RIT .................................................................................................................................. 11
RIT API Initialization .................................................................................................................................... 12
Algorithmic Trading Example - Arbitrage ...................................................................................................... 18
Introduction

Rotman Interactive Trader allows users to program trading instructions in Microsoft Excel Visual Basic for Applications (VBA) modules. The purpose of this is to allow for program or “algorithmic” trading, where the computer executes trades based on a pre-described set of instructions or parameters.

This tutorial document assumes that the user has no previous knowledge of VBA, and begins by discussing the concepts of programming before in-depth trading algorithms are introduced. Those who are already familiar with VBA should skip to the section entitled “API commands for RIT”.

This document also does not discuss the strategies behind algorithmic trading. Rather, it introduces the user to the tools that are available through the RIT API. Users are encouraged to explore possible strategies and techniques and use the building blocks here to implement them.
Introduction to Excel VBA (Developer)

To access the VBA editor in Excel, first ensure that it is turned on by clicking on “File” on the top-left corner of the screen, then click on “Options”. Once the “Excel Options” window is opened, choose “Customize Ribbon” on the left menu bar, and ensure that “Developer” on the right side is checked. Once this is checked, the Developer Tab will appear in the original list of Excel tabs.

You can access the VBA editor by clicking on the “Visual Basic” icon within the Developer tab.  
*Hint: You can access this at anytime with the shortcut Alt+F11*
The VBA editor will display all of the loaded Excel projects and add-ins. What is relevant is the VBAProject (Book1) that you are currently working on. Note: Book1 refers to the name of your Excel spreadsheet file and will change as you change your filename.

![VBA editor window](image)

We will begin by writing some basic procedures in your Book1.xls. In order to do this, create a module in your book by going to **Insert -> Module**.

Module1 will be added to your Book1 project and a code window will open on the right hand side allowing you to input your programming code.

The first step is to write a very simple procedure. A procedure is a set of programming lines that are run by the computer whenever instructed to do so. Procedures are defined with the lines “sub <procedure>” and “end sub” enclosing them. We will define a procedure named “message” by inputting “Sub message” into the code window. As soon as you type “Sub message” (without quotes) and press enter, VBA will automatically format the text by adding brackets after message and add “End Sub” to the next line.
We have just created a procedure called “message”. When this procedure is run, it will execute the code. In this case, it will do nothing since we have not written any code between the beginning of the procedure (sub) and end of the procedure (end sub).

We will start with a basic set of code that references the built-in VBA function “MsgBox”. To do this, type “MsgBox ("Hello World")" into the code window between your (Sub) and (end sub). The "MsgBox" command will cause a pop-up message box to show up in Excel when the code is executed. After you have typed the code into the window, click on the “Play” button in the VBA editor, your code will execute and a pop-up message in Excel should appear.
You have just completed writing and running a procedure in VBA. Obviously running the procedure from the VBA editor is rather cumbersome, so the next step involves linking the macro to an Excel button so that it is easier to run the procedure.

To create the Macro button, go back to the Developer tab in Excel and click on Insert, and then select the first option “Button”.

```vba
Sub message()
    MsgBox(“Hello World”)
End Sub
```
When you move your mouse over the spreadsheet, the mouse cursor will become a crosshair instead of an arrow. Click and drag anywhere on the spreadsheet to draw the button. Once you finish drawing the button, the “Assign Macro” form will appear, select “message” (the name of your macro you just written) then click OK. Now that you have assigned the procedure “message” to the button, the procedure will be executed each time you click the button. Note: If you change the name of your procedure, do not forget to re-assign your Macro. In order to re-assigning the macro, you will only need to right click on the button and then select “Assign Macro”.

Once that is complete, left-click on the button and your “Hello World” message box should appear. If you ever want to edit this object (resize, redirect, etc.) right click on it and a context menu will appear allowing you adjust the box.

To understand a little bit more behind the programming, we will revisit the code and modify it to be slightly more complex. In the Visual Basic Editor, we are going to modify the code to read “MsgBox Cells(1,1)” instead of “MsgBox (“Hello World”)”.

Much like Microsoft Excel, VBA assumes that any text wrapped in “quotes” is plain text, whereas anything not wrapped in “quotes” is a function, procedure, or operation. Since there are no quotes around “Cells(1,1)”, it will not say “Hello Cells(1,1)”, instead, it will follow the command of Cells(1,1).
The Cells(x,y) command is a function in Excel that instructs VBA to replace itself with the data from the spreadsheet row x, column y. Essentially the way VBA interprets this set of code is:

MsgBox("x") “Create a message box with the text x”

Replace ("x") with Cells(1,1)

Will now use the data from the cell located in row 1, column 1”.

MsgBox Cells(1,1) “Create a message box with the data from row 1, column 1”

Now go to the Cell A1 in the current Excel Sheet1 and type in “Bob”. Click on your Macro button, the result should be a message box that says “Hello Bob”. Hint: If you want to reference cells from other sheets, you can do this by typing Sheet3.Cells(1,1). This will now use the data from cell A1 on Sheet3. We can make this more complex by adding an equation into the procedure. Go back to the VBA editor and change your code to the following:
Go to your Excel Sheet and type “Sally” into Cell A2, and click your macro button. The result should be:

To clean this up a little bit, we will make another adjustment to the code by adding the word “and” between the two references. This is accomplished as follows:

```
Sub message()
    MsgBox Cells(1, 1) & " and " & Cells(2, 1)
End Sub
```

Notice the quotes around the word “and”, as well as the space between the quotes and the word “and”. Without the spaces, the message box would simply say “Bob and Sally”. Alternatively without the “quotes” around <and>, VBA would think “and” is a command instead of using it as “text”.

The last code adjustment that we will make is to add a mathematical equation to our message box. This is accomplished as follows:

```
Sub message()
    MsgBox Cells(1, 1) & " and " & Cells(2, 1) & Cells(3, 1) * Cells(4, 1)
End Sub
```

Type the values “3” and “5” into cells A3 and A4 and run your procedure by clicking the button. The result should be “Bob and Sally15”. Since we used the asterisk “*” between Cells(3,1) and Cells(4,1), VBA is instructed to multiply the values from these two cells, and then append them as text to the rest of the text.
This concludes the basic VBA training that you will need in order to access the RIT API. You are now able to write a simple set of instructions (a procedure) in VBA using a predesigned function (MsgBox) and execute it via the Button that was created. In the next section, you will use the skills that you have learned, and apply them to trading!
API Commands for RIT

Setting up RIT API configuration

Application Programming Interface (API) commands in Excel VBA can retrieve information from, and perform actions on Rotman Interactive Trader (RIT).

To begin, start with a NEW spreadsheet and access VBA. In order to access RIT’s built-in VBA commands, you will need to add it as a reference to your VBA project by going to: Tools -> References

When the Reference window appears, scroll down and check the item “Rotman Interactive Trader”. This step loads the Rotman commands and functions into VBA so that you can reference them. Next, create a module in your file by going to Insert -> Module.
**RIT API Initialization**

Then, initialize a new Rotman Interactive Trader API object using the following code:

```vbnet
Dim API As RIT2.API
Set API = New RIT2.API
```

One the RIT API object is initialized, you can start writing API commands. In general, the syntax for an API command is made up of 3 main parts: the object, the method, and the parameter(s) (optional), as demonstrated in the following sample code:

```
API.CancelOrder (order_id)
```

In this example, *API* is the **object** that actions are performed on. The **method**, `CancelOrder`, is the action to perform on *API* (in this case, the action is to cancel an order). The **parameter**, `order_id`, specifies details of the action (here, it specifies the order ID of the particular order to cancel).

Depending on the action that a method performs, it may or may not require a parameter. In the example above, `API.CancelOrder` requires a parameter to specify which order to cancel. In the following sections you will see examples of methods which do not require a parameter. These methods perform general actions. There are also examples demonstrating the use of more than one parameter, separated by a comma.

Other than performing actions, methods can also return a result (called the return value). It can be stored in a variable or a cell in an Excel worksheet for later reference. The example `API.CancelOrder` does not have a return value.

**Submitting an Order**

The following command adds an order to RIT.

*General command Syntax:*

```vbnet
API.AddOrder(ticker, size of trade, price of trade, buy_sell, lmt_mkt)
```
### Parameters:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
<th>Possible Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>ticker</td>
<td>Ticker symbol of a stock</td>
<td>“ALGO”, “CRZY”, Range(“A1”), etc.</td>
</tr>
<tr>
<td>size of trade</td>
<td>Bid size or ask size</td>
<td>500, 10, Range(“A1”), Cells(2,3), etc.</td>
</tr>
<tr>
<td>price of trade</td>
<td>Bid price or ask price*</td>
<td>10.00, 15.25, Range(“A1”), Cells(3,4), etc.</td>
</tr>
<tr>
<td>buy/sell</td>
<td>Buy or sell an order</td>
<td>Buy order: API.BUY or 1**</td>
</tr>
<tr>
<td>lmt/mkt</td>
<td>Type of an order</td>
<td>Sell order: API.SELL or -1**</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Limit orders: API.LMT or 1**</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Market orders: API.MKT or 0**</td>
</tr>
</tbody>
</table>

* When inputting a market order, the price of trade must be specified with an arbitrary number. This number will be ignored as all market orders transact at the market price. See example in sample code 2.

**While you can code the buy and sell parameters directly with API.BUY and API.SELL, or indirectly with 1 and -1, if you are referencing cells you must use 1 (for buy) and -1 (for sell). You will get an error if you reference cells containing the corresponding text values API.BUY and API.SELL. The same applies to referencing lmt_mkt parameters. See example in sample code 3.

Let’s start by simply submitting a buy order. This can be accomplished with the following code:

```vba
Sub submitorder()
    Dim API As RIT2.API
    Set API = New RIT2.API
    Dim status as Variant
    status = API.AddOrder("CRZY", 1000, 5, API.BUY, API.LMT)
End Sub
```

Note that the example is setup assuming that students are trading a case with a stock “CRZY”. If you are trading a different case, you will need to change the ticker otherwise the command will not work since the security “CRZY” does not exist.

As you type the beginning of the command “API”, you will notice that a dropdown box will appear showing all of the different API commands that you can access.
You will also notice that as you type in the API.AddOrder command, a tooltip will show you the different command line parameters that are required for the API.AddOrder command.

Once you have completed the code, you can click on the red Play button in order to run the procedure. Click the button a few times and visit your RIT Client, you should see limit orders placed at $5.00 to buy shares of CRZY.

**Return Value:** True or False

There are a few sample codes you can try in order to practice submitting different types of orders. Please feel free to try them.

**Sample Code 1 – Limit Order:**

Submit a limit buy order for the stock CRZY with size 1000, at a price of $5.00. Assign True to the variable status if the order is successful, and assign False otherwise. Use “Range” to call cells that contains volume and price information. (So in this case, you should type 1000 in cell A1, and type 5
in cell A2 as they are referenced for volume and price, respectively.) Note that Alternative 2 uses 1 instead of API.BUY and 1 instead of API.LMT.

**Alternative 1:**

```vba
Dim status as variant
status = API.AddOrder("CRZY", Range("A1"), Range("A2"), API.BUY, API.LMT)
```

**Alternative 2:**

```vba
Dim status as variant
status = API.AddOrder("CRZY", Range("A1"), Range("A2"), 1, 1)
```

**Sample Code 2 – Market Order:**

Submit a market sell order for the stock CRZY with the size found in the cell A1 at the market price. Assign True to the variable status if the order is successful, assign False otherwise. Note that the sell price is specified here (with an arbitrary number, 1) even though it is ignored.

**Alternative 1:**

```vba
Dim status as variant
status = API.AddOrder("CRZY", Range("A1"), 1, API.SELL, API.MKT)
```

**Alternative 2:**

```vba
Dim status as variant
status = API.AddOrder("CRZY", Range("A1"), 1, -1, 0)
```

**Sample Code 3 – Referencing Cells for buy_sell:**

Submit an order for the stock CRZY with the size found in the cell A1 at the market price. Assign True to the variable status if the order is successful, assign False otherwise. Whether the market order is to sell or buy depends on the value in the cell A2. Note that if a cell reference is used for the buy_sell parameter, the number value must be used in the cells. In other words, the cell A2 must contain 1 or -1. The strings “API.BUY” or “API.SELL” will not work.

Referencing cells for the lmt_mkt parameter follows the same pattern. The cell being referenced must contain 0 or 1 instead of the text “API.LMT” or “API.MKT”.

```vba
Dim status as variant
status = API.AddOrder("CRZY", Range("A1"), 1, Range("A2"), 0)
```
Sample Code 4 – Using AddQueuedOrder:

Similar to AddOrder, you can also use AddQueuedOrder to submit a limit or market, buy or sell order. While all the parameters for AddQueuedOrder are the same as for AddOrder, the difference lies in the return value. While AddOrder returns True/False, AddQueuedOrder will return -1 (for failure to submit an order when the case is inactive), 0 (for failure to submit an order when the case is active) or any positive integers (for successful order submission).

\[
\text{Dim status as variant} \\
\text{status} = \text{API.AddQueuedOrder("CRZY", 1000, 5, API.BUY, API.LMT)}
\]

Cancelling an Order

The following command cancels an order based on the order ID specified by the parameter.

**General command Syntax:**

\[
\text{API.CancelOrder (order_id)}
\]

**Parameters:**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
<th>Possible Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Order_id</td>
<td>Order ID*</td>
<td>3142, 2323, Range(&quot;A1&quot;), etc.</td>
</tr>
</tbody>
</table>

*Order IDs can be retrieved via the RTD functions – refer to the “Grabbing Ticker Specific Data Fields” section from the *RIT - User Guide - RTD Documentation.pdf*. *

**Return Value:** None

There are a few sample codes you can try in order to practice cancelling orders. Please make sure that you have submitted orders before try cancelling them.

**Sample Code 1:**

Cancel the order with the Order ID 1500. Usually, you would make this more robust by linking the value to a cell location with the Cells(x,y) or Range("mx") functions as in Sample Code 2.

\[
\text{Sub cancelorder()} \\
\text{Dim API As RIT2.API} \\
\text{Set API = New RIT2.API} \\
\text{API.CancelOrder (1500)} \\
\text{End Sub}
\]

**Sample Code 2:**
Cancel the order specified in cell A1

    API.CancelOrder (Range(“A1”))

**Cancel Order Expression**

The following command cancels all orders that satisfy the expression specified in the parameter.

*General command Syntax:*

    API.CancelOrderExpr (order_expr)

**Parameters:**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
<th>Possible Values*</th>
</tr>
</thead>
<tbody>
<tr>
<td>order_expr</td>
<td>Order expression</td>
<td>“Price &gt; 20.00”, “Volume = 400”,</td>
</tr>
<tr>
<td></td>
<td></td>
<td>“ticker = ‘CRZY’”,</td>
</tr>
<tr>
<td></td>
<td></td>
<td>“Price &gt; 20.00 AND Volume = 400”,</td>
</tr>
<tr>
<td></td>
<td></td>
<td>“Price &gt; 20.00 AND Volume = 400”, etc.</td>
</tr>
</tbody>
</table>

* Available operators include = (equal to), <> (not equal to), > (greater than), < (less than), >= (greater or equal to), <= (less than or equal to). You may also use brackets “()” to clarify order of operations.

**Return Value:** None  

**Sample Code 1:**

Cancel all orders that have a price greater than $20.00 and a volume equal to 400.

    API.CancelOrderExpr (“Price > 20.00 AND Volume = 400”)

**Sample Code 2:**

Cancel all orders associated with the stock CRZY.

    API.CancelOrderExpr (“ticker = ‘CRZY’”)

**Sample Code 3:**

Cancel all orders that have a price greater than $20.00 and a volume equal to 400, or all orders associated with the stock CRZY.

    API.CancelOrderExpr (“(Price > 20.00 AND Volume = 400)
    OR ticker = ‘CRZY’”)

*Copyright © 2014, Rotman School of Management.*
Algorithmic Trading Example - Arbitrage

This example assumes that students are building the arbitrage VBA codes while they are connected to RIT Client with the ALGO1 case running. By default, the case runs for 300 seconds and there is one security that is traded in two different exchanges – CRZY_A and CRZY_M.

Before we start, please make sure that Rotman Interactive Trader is enabled in Tools → References. (Please refer to the “Setting up RIT API configuration” section in page 10). Once you create a new module, you should type into the code-box on the right hand side of the window and define a function. In this example, the function will be called “arb” and it will have one parameter called “timeremaining”.

While there are many other ways to switch on/off the arbitrage algorithm, we will use the “timeremaining” to signal when the algorithm can start and stop. Once we initialize the RIT API, we can have the following ‘if statement’ to control the time that the algorithm is turned on and off.

Operationally, every time the “arb” function is run, Excel will initialize the API, and then check to see if the time remaining is between 5 and 295. As shown in the above example, the code currently initializes the API and allows for algorithmic trades to be submitted if the time remaining is between 5 and 295. (However, it will not submit anything because there are no commands written after the IF statements yet.)
The VBA codes are now setup to run the arbitrage function whenever the case is running. The last step is to go into the code and program the logic to check for arbitrage opportunities, and execute the appropriate trades.

Before we setup the codes, it is suggested to have the market data from RIT and bring it to Excel using RTD links, so that we can analyze it with our algorithm.

Now with this data linked in Excel, we can use an IF statement in our algorithm so that it only executes the buy/sell pair or orders when an arbitrage opportunity exists. Hence, the logic should be to check for two potential arbitrage opportunities:

If the ask price of CRZY_A is less than the bid price of CRZY_M, then the algorithm should submit a market order to buy CRZY_A and a market order to sell CRZY_M.
If the ask price of CRZY_M is less than the bid price of CRZY_A, then the algorithm should submit a market order to sell CRZY_A and a market order to buy CRZY_M.

The code is presented as follows

Here, each cell is named with the security name and bid/ask information. As you can see from the example below (highlighted in blue) Cell B2 has been named as “CRZY_A_BID”, etc. This is not a required step, but naming each cell will help you understand the information it contains. You can use Range("B2") instead of Range("CRZY_A_BID")
The code sets OrderID = API.AddOrder because whenever an order is submitted to the API, it returns an “Order Identifier”. In our situation, we will not use the OrderID (in the future, one could use the “Order Identifier” to check the status of the order, cancel it, etc.)

Alternatively, this can be replaced with the examples of the codes we used in the “Submitting an Order” section above as shown below.

```
If timeremaining < 295 And timeremaining > 5 Then
    Dim status As Variant
    If Range("E2") > Range("C3") Then
        status = API.AddOrder("CRZY_M", 1000, 0, API.BUY, API.MKT)
        status = API.AddOrder("CRZY_A", 1000, 0, API.SELL, API.MKT)
    End If
```

Finally, in order to run the “arb” function, you would need to return to the spreadsheet, find a cell and type in “=ARB(E2)”

This will tell Excel to execute the function “Arb” and pass into the function the value from cell E2 (which happens to be the time remaining in the simulation). In this situation, the time remaining is 300 seconds, so the code in the “If” statement will not execute. Once the case is started (and timeremaining is < 295), then the code in the “If” statement will execute.

While the ALGO1 case is running, whenever the markets become crossed, the algorithm should automatically buy shares on one market and sell shares on the other and generate a profit.

**Excel runs the function (and the code) on a continual basis. Therefore, when students try to edit the code in VBA, it will cause an error (because Excel is trying to run half-written code). In order to proceed, students should delete the function =ARB(E2) in the spreadsheet before finishing their code, and then add it back later:**
Note that this is a simple arbitrage algorithm. Please feel free to try to improve this by making it more dynamic (i.e. link the order size and price to Excel), working out the gross/net limit restrictions in the case, etc.